Missing magical object

Hello all. 2nd floor of dream castle: I walk up the stairs from the 1st floor, I've opened the locked door a couple paces in, and there's a blue wall of force that demands a magical object. I have the pictish knife, scepter of love and have the orb key if needed. I have read and re-read the criteria to get to lady lotti's chambers, so I feel like I'm not even at the spot that needs the pictish knife yet. The only denizen I've spoken with here has been the first floor scullery maid who wants more food, needs a better education, but ultimately gave me the mother maab orb key directions. The question is: what is this magical object for this first blue forcefield?


  • Equip the Pictish Knife and hit the blue wall of force with it.

  • Yes, have done. That is the same knife pictured on my included graphic.
  • If all I need is the knife that clearly doesn't work, then I will try sleeping.
  • Nope. As usual, did not work, so will go to earlier save. This sort of thing occurs about 1 to 2 times per expansion. I'm going to blame my obsessive need to hoard game items at my house causing the game to get a bit ditzy. Will update if the pictish knife second time round doesn't work.
  • Still doesn't work. So. Any thoughts anyone? Restart expansion entirely or am I actually missing a quest or item? Prerequisites for that wall are the quests to rescue lotti and the pictish knife. Again, I feel it is too early to use the knife if the walkthrough is to be taken as instruction. Reason: reading the book about rescuing lotti states I should go through transporters to get to the stairs leading to lady lotti's chambers. The way the wording reads in the paragraph implies there is a wall of force at that point that requires the blade. As I am not through any transporters yet, perhaps I am at a different wall of force with a different magical requirement. Should I restart it?
  • edited February 2019

    You're in a different place. Sorry for confusion. You need the Orb Key there.

    To get the Orb Key if you don't have it, you need Pedsipec's quest Kill the Hell Spider: "For Pedsipec, Dungeon Masters’ Guild, Death's Sanctuary, break the Hell Spider’s web and kill the Hell Spider. The entrance to the Hell Spider's lair is in the Dun of Shadows to the north. You'll need Pedsipec's crossbow to kill the spider. It will drop a piece of Orb Key you can use with two other pieces to get an Orb Key made to help you reach Lady Lotti." and the quest Orb Key Pieces:

    "For Mother Maab, Strongbow Wood, bring her three pieces of Orb Key and she’ll make Merlin’s Orb Key for you." Mother Maab tells you:

    "[Merlin] sent one piece to be guarded by the Hell Spider.

    One is protected by the Dark Druid.

    And the last would be in the care of the Devil Dragon."

  • Thanks for the response cat, but I had the orb key.
  • Did everything again. Still nothing. I have a pictish knife, an orb key, a scepter of love and still a blue wall of force asking for a magical item.
  • Is Mother Maab's quest solved in your quest list?

  • Then it should work. I just tested this. Tap the wall of force with the Orb Key in your inventory.

  • As much as I sincerely appreciate the help, I have done what you say, but then I've said that I had done that even in my first message and have picture evidence of the game message that comes up. Perhaps I have not been clear. Have done this hitting of the wall with the orb key in inventory now countless times and even rotated through every weapon in my inventory from the expansion as the hitting tool, including the two I've mentioned twice now. Did it after sleeping in inn 21 times and after resetting to earlier save file and starting back in. I honestly cannot figure what else I can do. If my only requisite for that wall is the orb key, then perhaps I need to delete the expansion and reload it? Start entirely from scratch.
  • If tapping the wall of force (not hitting it) with the Orb key in your inventory doesn't work, then yes, you probably have some kind of glitch. I tested this and there's no problem. Did you try tapping the wall of force?

  • In the backup save file version it worked by tapping; originally it did not. Now I can finish. Thank you!
  • I'm glad it worked. I should have paid more attention to where you were. I thought you were in Lady Lotti's Chambers for some reason although you clearly said you were on the second floor. I'll go iron my hands.

  • Back away from the iron! We need those hands in perfect working order to make more delicious questy treats. Thanks again. Continued lessons for having backups! At least I didn't have to delete it and start again this time.
  • I freed Habren/solved wheel of time quest way way early the first time through since I tapped next to Merlin and got his extra key. I wonder if that bungled things. Second time through I didn't mess with obtaining the key before I was supposed to and was able to use the orb key tapping fine to get through dream castle force field. Just a thought.
  • If you have more than one Orb Key, you'd have to drop one as the script checks for one. Will take a look though. Thanks.

Sign In or Register to comment.