Problem Clearing Broono's Quest

I have run into a spot of bother clearing Broono's quest (Test the sphere). What happened was this:

Somewhere I found another Destruction sphere (indistinguishable from the one Broono gave me) before I got to the Testing Grounds. At the Testing Grounds whichever one got tested first was not very powerful while the other one destroyed the statues. When I returned to Broono the only talking choice was "About the Guild", nothing about the task. Thus I am unable to complete the quest.

Have I found a bug? Or is there something else I must do or someone else I must talk to?

Thank you.


  • I don't see any bug. Go back to the Testing Grounds maybe and step on the floor switch again. Broono tests the state of the floor switch and if the statues disappeared, you did what you need to do. But try stepping on that floor switch again and then go back to Broono.

  • I have done as you suggested, but it did not make any difference. In fact, I tried several times just to make sure, but no luck. I guess that I will have to go back to the last save that I have which only has Broono's Destruction sphere and resume from there.

    Thanks agan.

  • It should work. I've done it many times in testing.

  • I think the problem is related to that second Destruction sphere I picked up somewhere. The reason that I say this is because I have just done some testing using a save file where I only had Broono's Destruction sphere.

    In the situation where I ran into the problem, I entered the Testing Grounds with two Destruction spheres, stepped on the switch, stepped off of the switch and immediately stepped on the switch a second time (which destroyed the statues) and later visited Broono. What I did this time was go to the Testing Grounds with only Broono's Destruction sphere, stepped on the switch (and got my toes burnt), immediately Recalled to East Point, talked to Broono and got a new (and improved) Destruction sphere, returned to the Testing Grounds, stepped on the switch and destroyed the statues, immediately Recalled to East Point, and talked to Broono (which successfully completed the quest). So it looks to me like the problem is caused by testing two spheres in a row without visiting Broono in between.

    Now as to where I found that second Destruction sphere, I cannot really recall. The last save file that I have without it is in Odettia just befor entering the Tower of Impatience. The next save file was made after going through said Tower as well as all of Beanfield, Squirrel Forest, Cygnusium, Firebird Slope, and Extinct Volcano, so I must have stumbled across it somewhere in one of those.

    Looks like it is just a case of needing to do things in their proper order without skipping any steps.

  • The script tests whether you have one of the spheres. I think had you dropped the second sphere it would have been fine. Sometimes I put a second item in because people are always losing things.

Sign In or Register to comment.