Can't find the treemaster in Old Shaman's Forest

I'm currently playing the Celtic Rift expansion on android and I'm dwawing a blank at finding the treemaster in the Old Shaman's forest. I've taken a look at the explanation in the faq, but even after walking over each of the green X's multiple times (with the grey druid cloak from the right buddah equipped), no tree has appeared or dissappeared. Therefore, the northern buddah won't give me the invisability cloak. I've also tried to sleep for 21 day at the inn, but this didn't change anything. Can anyone point me in the right direction to solve this quest? Thanks!


  • edited December 2019

    Dreader wrote some hints:
    There are 3 statues here, and some trees that move around. Talk to each of the statues. Two want you to talk to the trees, and one wants a Green Beer and a book of Magic tricks. Keep walking toward the trees and they move. Do it a few times and talk to the statue on the North wall who gives you an invisible cloak. Approach the trees wearing it and they say hi. Then see the middle and North statues for a well done and some knotted rope.

    Hand in the Relieve Boredom quest to the statue on the East wall for exp and a Druids Robe (meh). Go North twice.

  • edited December 2019

    I have already tried to follow these hints, but even after running around in the old shaman's forest for a couple of hours not a single tree has moved, so the northern statue won't give me the invisibility cloak. Talking to the statues or solving the quest for the eastern statue didn't help. I fear my game may be bugged.

  • It's possible your game is glitched or you may have too many expansions enabled. The tree scripts check a global and sometimes with so many expansions enabled, the engine can get confused. Did you check the map I put up? You see those x's on the ground? Those are the scripts for the trees. Keep walking over those x's and go back to the northern statue.

  • I did try to run over all the x's, but nothing happened. The only other expansion I'm running is island of ice and fire, but I can't disable it since my save games require it. I guess I'm unlucky and my game is glitched. Thanks for your help though!

  • Is there a way for me to continue without starting a new game? I would love to continue this expansion (and the others!).

  • Have you talked to all three of the Bhuddas in Old Shaman's Forest?
    Let me know. I could give the items the Bhuddas give you to Phredd or Mrs. Phredd to sell. And then you could see if at some point the forest works for you but it won't matter if it doesn't.

  • I have talked to all three Bhuddas. The eastern Bhudda gave me the Druid robe after the Relieve Boredom quest. The Bhudda in the south tells me to find the tree master and the Buddah in the north tell me to "try harder to catch the Tree Master" and won't give me the invisibility cloak.

    Thanks for your help and very rapid response!

  • So you need the Invisibility Robe and a Knotted Rope. I'll give them to Mrs. Phredd to sell. Then you can go back at your convenience and see if things work out there later on. It's not critical.

  • Next update Mrs. Phredd will sell the Robe of Invisibility and the Knotted Rope. She's in Wizards' Lair.
    Please, please keep more than one save file in case you get a glitch.
    I always keep at least four.

  • Thanks, that would be great!
Sign In or Register to comment.