Mita

Hi, I can t find mira to close build a bridge quest and get back lost memories. Thank you

Comments

  • Mita is across the path to the east of George's Hut in River of the Addancs. Cross the path, walk a step north until you get a message you see something in a bush, then try tapping the red bush there. If you have the quest Talk to the Addanc Mita from Halbor, tapping that bush should help you.

  • I have the quest takk to advance mira and I closed it. I walk all around the red Bush near the bridge I ve fixed for George but nothing happens

  • Mita shows up twice. Once if you tap the red bush. I know you walked around it, but did you tap the red bush? If you had the quest to build the bridge and you built the bridge if you tap the red bush, you should talk to her.

    Then she becomes visible after she rewards you for building the bridge and then you can talk to her about memories.

    Did you tap the red bush, not just walk around it?

  • Yes, I taped the brush. Still nothing

  • Try sleeping in an inn for 21 sleeps in another part of the world and then go back and see if things improve. That resets the game. Sometimes save file glitches happen and that can help.

  • Hi, I 'm Nico7550 and it's my first post.

    I post here because it's Mita related.

    I got and finish the quest "talk to the addanc".
    Cannot remember if I speak to mita but I have the "Addanc Sight" hability.
    But I don't have the quest "build a bridge" (I have an iron maul and 5 bags of wood).
    And tapping the red bush near the wood plate in river of the addanc does nothing.

    I wait 2 times over 21 days in inns located outside the zone without any reset.

    Thanks

  • Quest is For Addanc Mita in River of the Addancs, build a bridge so that old George can cross.

    If you got the Addanc Sight ability, you had to build the bridge.

    Unless you bought the Addanc Sight Ability by talking to Phredd about Mita. In that case, you can't get the Build a Bridge quest.

  • Thanks Cat, Phredd I ate this guy now ! May I ask if you have some technical information about the bytes for the ability part in the save file ? I manage to add the quest 57 (build the bridge) but as I have the sight it's useless. I saw where are stored the ability and the ability counter just before, but removing ability and decreasing the counter is not enough... maybe you know what are the informations store after the ability list (before the recall list) ?

  • edited February 14

    That's all programmed by Redshift. I've never even tried. What is that table? How did you add the quest? You hacked your save file? : ) How?

  • OK, it remember when I was exploring Might & Magic 3 save when I was 12...

    So open your save file with an hex editor

    search for the quest, the first quest of the main game is "base_main"

    The problem is that I know the quest related code, for build the bridge, you give it in another thread, it's celt_q57. For the others unless you have a list, it will be a long testing...

    So go at the end of the list of quest

    A quest is compose of 3 things
    The quest name
    a byte as separator
    a byte indicate the status 0 not done 1 done 2 fail

    Duplicate one block

    Change the name and the last byte

    Last part, the game have a count of quest, it's in the first part of the list of quest, the 2 first bytes before the first quet name and it's inverted...

    Here I have A001 and if I count my quest, I found 416, so in hexa 01A0... to add one I will have 01A1 and in the file A101 because it's inverted

  • edited February 15

    What hex editor did you use? The entry for the Addanc Sight ability is celt_addsight. I don't know if that helps you. Effects +15 Accuracy, +10 Armor, +5 Intelligence +10 Environment Magic. If you just have the quest, you should be able to build the bridge.

    if(evtstepon() && (player.hasquest("celt_q57")) && (player.hasitem("celt_weap_maul2",1)) && (player.hasitem("celt_wood",5)) && (getstate()==0))
    {message("You use the wood and fine hammer to build a stout bridge.");
    player.removeitem("celt_wood",5);
    celt_bridge1.setvisible();
    celt_bridge2.setvisible();
    celt_bridge3.setvisible();
    celt_bridge4.setvisible();
    setglobal("celt_bridge",1);
    setstate(1);
    }
    else
    default();

  • I use HxD https://mh-nexus.de/en/programs.php

    Yes when I have the quest I may build the bridge (quest in statut 0 or 1), but has I ever have the ability, Mita didn't show.

    What are the condition for the other addanc quest ? For example how the quest for Gap Tooth or Dripina appear ?

    Revoming the ability will need to take some test, starting a new game for celtic rift, then save at the begining, try to get the iron maul and the 5 bags of woods, going to arbor save after having the quest talk to the addanc, then going to mita to have the build the bridge quest, saving, then build the bridge, saving again, and last speaking to Mita and saving. Then comparing all the save file and the one I have to find what is the part only related to the sight and where it start and end... a couple of hour...

  • You don't have an older save file?

    Bannock Buns quest: For Gap Tooth in River of the Addancs, bring him thirty bannock buns so he'll blow up the dam.

    Blow up the dam quest: For the Addanc Dripina in River of the Addancs, blow up the dam that keeps the Addancs contained there.

    I've never even tried to hack a save file. You could write elendil@redshift.hu. If he's not to busy, he might be able to help. But he doesn't know the expansion and generally he's very busy.

  • What platform are you playing on? If it's Steam, I might be able to help you. Not sure.

  • Nope I only have my current save file, I'm playing on android.

    For the 2 quests, may I have the code condition as the one you share for celt_q57 ?

    If you mail Elendil, just ask him the technical specification for the save file, no need for more, if I know what is what I may try to handle it myself.

    Thanks

  • I can't bother Elendil but you can write him yourself. Tell him you're a coder and a bit lost and don't want to bother him but you could use a bit of help. Tell him I don't have a clue.

    Here are the quest conditions.

    Bannock buns celt_q44

    Blow up the dam celt_q53

  • After exchange with Elendil, he accept to remove the ability from my save game, but:

    1. it's impossible to reproduce, too much places are touched...
    2. it didn't change anything, MITA still didn't appear...

    I will be oblige to cancel the quest... sad
    Thank you anyway

Sign In or Register to comment.