Awaken the Bogatyrs

Hi,

I have a problem with completing the Awaken the Bogatyrs quest. I found 4 statues in River Subterra, 1 in the Village of Peklo, 1 in the Village of Ray. Each statue first says something, and then it is said that it is in a "deathlike slumber". I have live water, but it was not consumed during my interaction with the statues. What may be wrong?

Comments

  • Is enough just to touch all of them. After each of them reveal some valuable advice, means that they took live water and that's it.

  • Thanks Aeon!
    Still, I cannot complete the quest after touching all 6 statues...

  • Strange...so Dragon Slayer says nothing when you go back to him?

  • edited May 19

    This might be another case where the Quest gets confused counting globals if you have too many expansions enabled. Try disabling some, sleep in an inn for seven nights and seven days and go back to Dragon Slayer and try again.

    This is a problem as more expansions have been added and Elendil cannot find the problem--it's elusive. In the new expansions, I try to avoid using globals but in the old expansions it's to hard to change so many places.

    Make sure each Bogatyr gave you a hint. To make sure, go back to each one with Live Water and see if you get a hint.

  • If you're playing on Steam and send me your save file, I can check this.

  • I think also part of your problem might be that Live Water is also available in HOLII but it's different Live Water. You might not have the Live Water from HOLIV that the Bogatyrs' crave. Drop what you have, get some from HOLIV and see what they say, then talk to Dragon Slayer.

  • Thanks Cat! The live water is from this expansions, so this is probably the problem with counting globals that you are talking about. All the six Bogatyrs have already said something but Dragon Slayer says that I have not awakened all of them.

    I use Android. In my game, all currently released HD expansions are enabled. Also, I probably have a similar problem with the "Find the pollution" quest in one of Celtic expansions (I cleaned all the polluted cells that I could see with a special brush but the quest cannot be completed). Anyway, these particular quests are not that important for me.

  • The 'find the pollution' quest in Celtic Rift also uses globals to count the pollution. So, yes, the problem is probably too many expansions enabled.

  • I seem to be a victim of the same bug. This is the last guild quest for me. I tried uninstalling the Celtic Rift expansion, but it didn't help. Any other advice?

  • edited June 29

    Elendil's advice is to go to a different level in the game with an inn. Sleep there for seven full days and nights to reset the game. It should help. He thinks it's not an engine bug but a save file glitch.

    I don't know of any other solution except to take the quest out and that would cause more problems than help.

  • Hmmm.... I tried this (10 days to be sure) and unfortunately it didn't help. I revisited the Bogatyrs and they are unresponsive.

  • Are you sure you spoke to all the Bogatyrs? They all just give you hints after you talk to them. If you did, I would just keep playing. Sometimes these things clear up by themselves.

  • I'm sure I spoke to each. They each gave hunts and are now silent.
  • What platform are you playing on?

Sign In or Register to comment.