Something went wrong

Hi, I solved the Wormiston Witches quest, went to Lord Alderley, then to Lord Caerworn, and he said „oh, you spoke to my father, cheerio“ and the Warn Sheets quest is soved. I haven‘t been to Sheets, due to the missing spoon. But the Feud quest is still open. What can I do?


  • Go see the person who assigned the task: pedispec in dreamers tower.
  • You can't solve the warn Sheets quest without talking to Sheets so something is wrong but not sure what it is. After you kill the Wormiston Witches and go back to Lord Alderley, he says, "My hand no longer bears the mark of the witches of Wormiston. I feel safe now from their power. Please take my gloves and this ring for your help. I know I made a promise to soften my heart towards my brother. Take this pledge of peace. Deliver it to my brother Lord Caerworn of Caerworn Castle."

    If you take the pledge to his brother in Caerworn Castle, and then go back to Lord Alderley and then to Pedsipec, you can solve the Feud quest.

    Your son probably already got the spoon which gets you the cake from cook that you need to talk to Sheets. So I'd stop looking for the spoon.

  • No, the cook still wants the spoon. And the doors to the cupboard are stuck.

    At Lord Cearworn‘s I only have the „Lord Caerworn“ option, bur Lord Aleerley still asks to take the pledge to his brother.

    I guess I‘ll have to get back to an old save file...
  • It looks that way. Are you sure you did the Warn Sheets quest?

  • And you went back to lady alderley?
  • To Lady Alderley?

    So this is what I did: I was on Dreamers‘ Island and got all the quests. Then I started exploring (as my son did, but not that much), went to Caerworn Castle to get the quests there, eg. „warn Sheets“ -> get chocolate cake-> find the spoon.

    As I couldn‘t (and still can’t) find the spoon, I went on exploring.
    Did the stuff for Lady Alderley, so she sent my to her husband. He was concerned about his hand so I got the „clean out the coven“ quest.
    Which I did. Coming back, he was happy and send me to Lord Caerworn to end the feud.

    During the meanwhilst I did nothing with the Sheets quest, as I couldn’t find the #%! spoon.
    Soooo. I went to Lord Cearworn, he almost cried wirh happiness that I warned Sheets, althou I clicked on „feud“. And *ssssst* „warn Sheets“ quest was solved, „feud“ wasn‘t an option anymore and Lord Alderley is pissed, because I didn‘t go to his brother.
  • The Magic Spoon is in a drain behind a tappable wall if you have the Cook's quest. I think your problems are coming from two people playing different parts of the game in the same save file. Caerworn is very story-driven and if you don't follow the story, you lose the thread.

  • Aaaahhhh, I was so fixated on opening the cabinet, that I didn‘t try anything else :-D

    I don‘t think it has anything to do with my son playing, as he mostly just ran around in the outside to fight monsters. That is what I do more or less in the beginning too.

    Soo: I now played the coven quest again, went to Alderley, but not to Caerworn, retrieved the spoon from the gutter (god, I feel so stupid), went to Sheets and got a second pledge. Could that have caused the glitch? The 2 pledges?
    I‘ll play on to see what will happen...
  • Yepp, all is well!
Sign In or Register to comment.