Alderley Castle and other stuff

Hi, I‘m upstairs in front of a door that wants me to do something. I tried bashing, magic, hitting all walls and ran out of ideas. There seems to be a spider suck in the wall, poor thing. I can see its legs.

I have not marked on Dreamers‘ island - how can I return?

I can‘t find the magical spoon. Is it in the cupboard I can‘t open?

I am to deliver contraband and bootleg whiskey, but I don‘t seem to have it in my bag - can it be sold? (My son played the game „for me“, so I‘m not sure, if he found the stuff at all).



  • I think you and your son should have separate save files. :smiley: The Quest engine sometimes has the strange effect of monsters bein seeable through walls. It's a rare engine glitch that seems unsolveable. Have to live with it.

    That's young Jon Alderley's door and if it's locked, your son already did his quest.

    You can get back to the Dreamers' Tower by going back through the Smugglers' Cave. Entrance is a hole in Caerworn Castle surface map in the west.

    The magical spoon is in a cupboard that you can't open.

    The bootleg whiskey can be sold but you can buy it back from a potion shop. You need 25 bottles to complete the quest.

  • Yeah, I made him start with Quest 1 now, with his own character :)
    I wasn‘t complaining about the spider, it just looks funny (but isn‘t the first time I saw it).
    I solved the Jon Alderley Quest, but it‘s one floor above

    How do I get the magical spoon then?

    Thanks for all the help!

  • Yeah, and I opened it - Catacomber magic....

Sign In or Register to comment.