Thor's Hammer FAQ

Use what the monster gives you-
The monster drops a Great Poleaxe. You need it to go further. You have to hit something with it. If you don't have one or the monster doesn't drop it as he should---you can tap something on a wall near there and get it if you haven't already.

To repair the switch in the Flooded Caves, you need repair greater than 17.

Repair the bridge to Holy Island--You need a Master Repair Hammer from the base game or from Ice and Fire.

For removing the trap that sends you back in St. Aidan's Crypt, there is a small three switch puzzle you need to do.

To close the hole in the Chevron Mines there is of course a switch and then you need to remove a rock by casting a hot spell.

To receive the gold hair from Forkbeard, you have to hoist it out of the ground where he keeps it.

Phredd is in the Arena of Flames.

The Sword of Sweet Revenge is in Bloodmail's Fortress.

How to get into Humbria Jail--go into Humbria Castle and speak to the guards around the lord's door. If your crime is high enough, they'll help you go to jail. You can get infected with evil in Humbria. A door in middle-right part of the town.
Villi--the keys for Villi-there is a crack next to the jailor, explore that.

Old Tunnels--there are four ways to get into the Old Tunnels--two drains in the village that give you entry. But there is also a hole in Foggy Islands. And a hole in Regnald's Basement.

Otto the Armorer sells a Miner's Axe.

The music scrolls are outside Lord Gorum's keep. Check the usual suspects--bushes, rocks, hollow trees, ponds.

Chest for Old Kon--you have to explore Hobbes' Hole. You get there from the Whispering Maze.

Cureall statue is in Brass Horn's cave. You have to step carefully over the void and remove a pillar by a switch in the far northwest.

Otto is on Bream Island.

If you need a rock—there's one in the base game. There's one in Jotunheim by Jotun on the ground that respawns.


  • Chevron mines. I activate the switch, it changes colour, but I don’t get the usual message to indicate that something has happened. Possible bug? Go upstairs, hole is still there. I can't find a rock to be removed. Am I missing something?

  • There is a message when you first activate that secret switch. And it closes a hole. BUT you have to hit it, not tap it. I think that's your problem. Go back and hit it.

  • I hit it with my weapon and voila! ... got the message. Thanks cat, I would have been stuck here forever without your help.

  • Stuck again. This time in the flooded caves. I have repair skill 65 and a master repair hammer, but can’t figure how to repair the switch. If I select “repair” with my hammer, I only have options to repair my Inventory, but not the switch. I cannot equip the repair hammer as a weapon. I tried other weapon type hammers, but no luck.

  • You just need Repair skill greater than 20 and this quest-'For Frosthyr the Ice Giant, Ice Caves, find his half-brother the Sea Giant Aegon and tell him the good news that he's an uncle.' Then a wall of force disappears. You might still get the message about the switch being faulty after you repaired it as it is basically a faulty switch.

  • Ok, I got the Frosthyr quest, and this broken switch became a non-issue.

    I don't know whether there will be an update to Thor’s Quest someday, but this would make a nice tweak. Until you receive Frosthyr’s quest, this switch is of no use to you, but the dialog box implies you need to fix it somehow, which is confusng.

    If you don’t have Frosthyr’s quest yet , it should read something like: “This switch is broken, but it is of no use to you anyway.... yet!”. Later, when you receive the quest, you can repair the switch and proceed.

  • There was a reason I had to leave the script the way it was. I tried something like that and for some reason it wouldn't work but will keep that tweak in mind after I finish Macha's Curse. Thanks.

  • I thoroughly enjoyed Thor’s Hammer, well balanced, many interesting quests, challenging but not too difficult. Bravo. Well done. I have finished all the quests except 2, and for these I still need the Blue Fairy’s permission to enter the fairy ring on the Foggy Islands. That said, I’m stuck in the Blue Fairy’s Eyrie looking North in front of a stubborn locked blue door, second door from the left, northwest corner. I have lockpick 70, Fairy Shaft in hand, and my pockets are bulging with keys: bloody, blue, Eyrie, gold(2) and red - plus a few others : basement, Servile, theieves guild & mine. Any hints how to pry this door open?

  • Thank you! And thanks for the specific details about the door you need help with.

    You need a key that's here on a shelf behind a crackeable wall.

Sign In or Register to comment.