Hi, LOVING THIS!!! Good n huge :) quick question... there are a few places I’ve come across where it says walls might crumble if hit, but no luck when hitting them. Do I need to smack them with a particular item in this game or can I just use my usual swords and keep trying?


  • You might need strength of a certain level or a quest but hitting is the usual. Where are you having trouble--what level? Did you find Paravel Jewellry? : )

  • I’ve literally just found it! OMG YOU ARE AMAZING

  • edited March 2018

    Sorry got so excited I forgot to answer you, can’t remember exactly, somewhere near beginning. I’m level 47 now, think I was about 43 when I started

  • It was dun of dead. Broke walls but still I can’t get through one last gate. Got the key which leads to another gate which comes up with message about forgetting how many steps?

  • You need to flip both switches up in each of the corridors--the one on the left and the one on the right. Then---flip the switch in the right hand (eastern) corridor down and after you've done that run, run, run back to the left hand corridor switch (western) corridor and flip that switch down. That will open a gate. The switches are tap, not hit.

  • Ah, it was conns tower... two cracks that I can see and a nearly dead guy. Keyhole in wall.

  • In Conn's Tower, for the keyhole, you need a key from a crack there.

  • Tried cracks in corridor that leads to door that curses you and two cracks next to the dying guy but all empty. I can see a crack behind the dying guy that I can’t access. Tapping on the keyhole br8ngs up "nothing happens”

  • Here's the right crack--

  • Tap, not hit.

  • This one. Yup, tapped it and it’s empty

  • If it's empty, that means you either used the key or lost it. It's not sellable. If you used the key on that switch, it set a monster--a spider visible and gave you a diamond. That's all that switch does.

  • Tried a couple of earlier saved games and still empty :(

  • I just went into the game to test it and I got the key if I tapped the crack and used it on the switch (keyhole) and the spider appeared. Try tapping with your finger. Sometimes on mobile that works better. There's not much I can do about this as it works for me. It's not important enough to give the key to Phredd as there are plenty of spiders to kill.

  • Ok doke :) thanks hon.

Sign In or Register to comment.