Bubbles at the 3rd floor


At the third floor of Kozney's castle, there are bubbles close to the entrance. The first bubbles can be passed with Disarm, but then I cannot pass the second bubbles. Argimon's guide http://catacomber.com/discussion/20/hero-of-lukomorye-iv-argimons-guide-to-his-castle says that Disarm must be cast twice, but for me this does not work, I am still pushed back. What are the exact actions to pass them? Can wrong actions make them unpassable?


  • It should work. I just tested it. Cast the spell. Walk forward. You'll get pushed back. Cast the spell. Walk forward and you hear the words "Shhhh" and you are no longer pushed back.

  • Hi Cat! Thanks, but still no success with this action sequence (I still get pushed back, no "Shhhh" shown). Can you confirm that wrong actions (e.g. wrong spell, disarm cast too many times, hit) cannot block the correct solution? I don't remember what exactly I did with these bubbles before I recognized a problem.
    In any case, I have a backup save file, but maybe somehow I can avoid re-playing several hours : ) Dealing with Kozney is really problematic!
    BTW is it on purpose that the bubbles increase my HP by 0?

  • Nothing that I know of affects whether it can work or not. It didn't work for me the first time in testing, but when I left the level and went back, it did. The first bubble is easy. The code is very simple. The second and third bubbles use slightly more complicated code that works with globals. One thing I've discovered is that the more expansions you have enabled, the more unstable globals can be. The global stores its variable in z. Now probably more than one or two or three expansions use the variable z. I now try to avoid using things like that or use letter combinations that are unusual. But this issue didn't come up for quite a long time. I'd recommend disabling some expansions if you have a lot enabled, sleep in an inn seven days and seven nights and go back and see if that works. I could do an update, but I'd like to wait to see if there are any other bugs and do them together.

    This isn't a bug because it worked for us all in testing and even now it works for me. But I keep very few expansions enabled. But it's a pain.

    The bubbles can increase your hp by 0 because of the way Argimon wrote his code. The Quest can wrap numbers to 0 or to a negative under certain circumstances because of the limited number of bits it can work with. I don't want to change Argimon's code because it could interfere with something he coded someplace else.

  • Since I have to do a different bugfix, I've made it so when you approach the first bubble and Kolobok talks to you, the candle on the wall is now blue and if you touch it, you'll skip over the bubbles. Also on the other side of the bubbles, there is another blue wall candle and you can skip back. That should help. But the advice not to keep too many questworlds enabled still stands as it creates havoc with globals.

  • Hmmm... the famous Global Variable design pattern : )
    Thanks a lot for this workaround!

  • I've just passed through these bubbles with the intended way (and before that, they also started decreasing my HP normally). The only things I did before were completing Rescue Dara in HOL I and hunting some monsters in Celtic Doom. No sleeping in inns nor disabling any extensions. Magic!

  • I think this has more to do with the wonky globals than magic. :)

  • I’m having the same problem with the second set of bubbles. Cast disarm twice. I’ve tried an earlier save but that didn’t work. I have no clue how to “disable” earlier expansions. Hopefully the update will come out soon. Thanks Cat 😊

  • I tried it again and it worked! I noticed that I was missing a quest listed on Cat’s quest list. I took care of that then went back to the spot to where the second set of bubble are. Yay, I got through all the bubbles! Happy dance 😊

  • have this very same problem. nothing worked for me so i reverted to an old save and teleported in and out by mark&recall. unfortunately the blue light inside that space does not teleport you back but instead to the same spot. i think that you might want to check. thanks...

  • You're right. I'll do an update. Thanks.

Sign In or Register to comment.