Sudoko Room in Yaz Castle

Any help appreciated
I am stuck on the second Sudoko puzzle. I have typed in the following numbers starting from the first line:-2,9,4&5,1,9,2,5,3,4 but a number that previously went click will show a reset message, apparently randomly.
I must be overlooking something obvious but I do not know what.


  • 9, 7, 2, 3, 4

    Click those. Otherwise, you get a reset. The final tap (4), sets that row's candle on.

  • Dear Cat
    Thank you once again for your help and your speedy reply.

  • Dear Cat
    In the certain knowledge that I am being a complete pest could you please tell me which row to start with. There are a lot more rows of numbers than the ones you gave me.
    I apologise again for being to dim to work it out from your reply.

  • I thought you were stuck on the second row. Those are the numbers to solve the second row. If I am misunderstanding your question, please let me know.

  • Dear Cat
    Sorry for the misunderstanding. This was due to me not reading the in game "How to Play Sudoko" book correctly.
    My wife has now solved the intermediate puzzle so we can progress in the game.
    Thank you for your patience.

  • I'm glad you can go on. : )

  • I really enjoyed the Sudoko Room - a pleasant diversion! The sign at the entrance isn’t quite right though. The door at the end of the first (easy) room (NE corner) does not require a pushbutton (there is none) and you don’t even have to complete the first puzzle or light the candles for It to open.

    The aforementioned pushbutton is used after you complete thIs second “intermediate” puzzle, and this opens the door to... well... your secret is safe with me!

    Oh, and thanks for the lovely headgear, I will cherish it always!

  • I will take a look, thanks and you're welcome.

  • I'm pretty sure I've solved the intermediate one - all the candles are on - but where's the pushbutton?

  • North wall - next to the candles.

  • NW corner of this area

  • Thank you!

Sign In or Register to comment.