Stuck in Mymber werewolf quest in Celtic Queen

Could anyone help please?
I think that I have found Mymber in the wolfs den dungeon, assuming that he appears as a Grey Wolf. I have both the Darkenmoon Mirror and the Wolfsbane but the only response I get from the wolf is a growl.
I am undoubtedly doing something stupid but what?
What makes this particularly frustrating is that this is the second time my wife and I have played this game and we did not have this trouble last time.


  • This is the right wolf. If you've found him and have more than one Wolf Bane in your inventory or somehow more than one Dark Moon Mirror, drop the excess and then tap him.

  • Thank you for your help. It looks like shop bought or freshly foraged wolfbane does not do the trick. It worked when I used wolfbane obtained from Granny Sage.
    Thanks again.

  • I found one entrance to this cave, with the witch blocking it. Is there another? How do I reach the rest of the map in the wolf den?
    I've searched the entire Silver Hills.
    Any help is greatly appreciated.
  • I should say that I got past the witch as well at the entrance.
  • This is the only area if the map I can access.
    Just wondering if someone can help so I can progress further.
  • Did you talk to the wolf there and guess his riddle correctly? He will remove a wall for you if you do.

  • I spoke to the wolf in the map pic I posted. He simply states that he is not Mymber.
    I searched the area for any hidden switches as well. No luck.
  • That map up at the top here is the map of the Wolves' Den. Doing a riddle for the friendly wolves removes a wall. You can tell which wall by the white square.

    Did the wolf offer you a riddle? And did you answer it correctly? He should have said, "I'm not he but I can open the way to where you might find him. Just answer me correctly. What is the French name for a werewolf?".

    If all he says now is he isn't Mymbyr, he should have opened that wall with the white square.

  • No riddle was offered. The spot on your map, where the white square is, is still closed on my map.
    The french name for a werewolf is loup-garou.
  • It sounds like a glitched file. The wolves offer you the riddle and remove a wall. I can't do any update right now to help you. Can you try an older save file? I tried this and everything works fine. What platform are you playing on?

  • edited February 2022
    The platform is Android, it's just a cell phone. A Galaxy S8.
    I tried an old save file from Celtic Rift when I re-started that. It would not list new quests, under Active Quests so I took snapshots of the details. It would however count the quests as completed once I finished the quests I had obtained during gameplay.
    The same actions would occur if I loaded that save file and tried to begin from Celtic Queen and Celtic Doom.
  • It could be that you have too many expansions enabled and the engine is getting confused. Your save file shouldn't be acting that way.

Sign In or Register to comment.