Romulo's place

Hi, I went accidentally in romulo's place without having the quest lift the curse. I hit the buttons randomly and the sign wrote (for example C -1) I left the place, and when I went again with the quest try tapping the buttons, the sign keep write 0. This happens in all the signs. Do you know what s HAPPENING? Thanx!!


  • The switch on the left increases the count and the one on the right decreases it. If you have too many expansions enabled, try disabling some. The engine may have trouble counting across so many. It doesn't matter whether you have the quest or not when you tap the switches, you just have to set each to the correct number.

  • How do I disable them in the mobile version ?
    Romulos Signs haven’t ever moved an inch up or down same with Argimons Fibonacci switches. I got the quest(s) first.
  • You have to write

    The code on all those is correct.

  • I solved it by cleaning up my inventory (couple hundred potions where made in that process) cleaning up my storage items stored in my house and rest for a whole day. After that I tried again and both kind of switches worked by chance.
  • It has something to do with the engine. I'm glad you got through. : ) I think the engine just can't search through so many things.

Sign In or Register to comment.