Return the Idol Quest

Not sure if this is a bug or its me, but here goes

I have the quest, return the idol for mokoshka, royal spiders silk.
Went to see manager Seamus, who gave me a new quest to lift the curse, so did this quest, went back to seamus, he was happy, then went back to see mokoshka, and mokoshka keeps telling me to return the idol, but Seamus doesn't acknowledge anything.

I loaded an earlier saved file, where I gave the idol back, got the new quest, and went straight back to mokoshka, without setting of to solve seamus's quest (loft the curse) now she acknowledges the quest and it is solved....

So I now have a quest that I cannot complete, and can't go back to earlier saved game now as I bloody well overwrote it by mistake!!!!!


  • Forgot to add, using a Nokia 8 Sirocco, running Android 8.1.0, security patch 1 june 2018

  • I'm confused. Which quest can't you solve? It sounds like you solved Mokoshka's quest by bringing her the idol. But she doesn't take it away. She tells you to bring it to Seamus. The weapon you need to equip to smash the statue and lift the curse for Seamus is the Idoloclast Hammer. The idol of St. Nelson has nothing to do with that. It's not really a bug--it's a question of sequence.

  • I got the quest from little spider, Mokoshka, in royal spiders silk factory. She tells me to return the idol of st nelson to manger seamus, veternal Cyclops shady rest retirement home.

    I have done that, given seamus the idol, when I go back to Mokoshka, she doesn't acknowledge it, and keeps telling me to return the idol...

    Heres what happened.
    Got the quest from Mokoshka, gave the idol to seamus, got seamus's quest to lift the curse, lifted the curse (used the idolcast hammer) seamus thanked me, went back to mokoshka, she doesn't acknowledge the idol has been returned.

    On an older saved file which I no longer have :(
    Got the quest from Mokoshka, gave the idol to seamus, got seamus's quest to lift the curse, went back to Mokoshka, she thanked me for returning the idol, her quest finished, then I did seamus's quest of lifting the curse.

  • edited June 2018

    You're supposed to go back to Mokoshka before you give the idol to Seamus. No one else reported a problem with this as far as I know.

    I can give the idol to Phredd to sell in HOLIII. Do you have the Veteran Cyclops Ring Manager Seamus gave you as you have to show that to Mokoshka.

  • All sorted, your were right, I had the veteran Cyclops ring in storage, put it in my inventory, went to see mokoshka, she solved the quest, so all done and dusted.

    Now starting hol2 :smile:

  • edited June 2018

    Yay! I figured that was it because you can't talk to Manager Seamus about the idol until you return the idol to Mokoshka and get the quest to bring him the idol. : ) The usual culprit is storage.

  • hello,

    I am in the silk factory, got the quest by the small spider. but I cannot smash the web which covers the idol.
    for some reason you cannot break the web it says..
    what to do?


  • You need the quest from Mokoshka, "For Mokoshka, Royal Spiders' Silk Factory, Grasslands, find the source of the oppressive feelings that afflict her workers and lift the curse."

    If you have that quest and TAP not hit the web, it should disappear.

Sign In or Register to comment.