Where’s Rhodo?

I can’t find Rhodo. I suspect Rhodo is NE of the transporter in Fire Canyon but he way is blocked by water.


  • I can't help you right now because I can't open my Quest Classic files. Not sure why. I'm sorry. Rhodo is there though.

  • Oh dear. I’m wondering if I need to be wielding something or hit something while wielding something.

    last time I tried this expansion was probably 5 yrs ago and I got terribly confused with all of the asteroids etc. That and how easy it was to die LOL! I have since become quite a bit better at playing the game even though I’ve been playing for 20 years on different platforms.

    Last month I decided to challenge myself and take on the HD Asteroids. It was so much fun I decided to revisit the classic. As I wait to find a solution (last 3 quests hinge on finding Rhodo), I’m checking out another classic that always kicked my but in the first day of game play Dragon Jade. Did I hear that you were in the process of porting it to HD. So far I’m doing way better than I did years ago.

    I hope you are able to open the files soon. Thank you for all that you do.

  • edited August 2023

    My problem is fixed. : )

    Rhodo is in the Fire Canyons on a door. A dark door in the middlish south. You can by the way cross the water to a hole if you walk very carefully in the far southeast but that has nothing to do with Rhodo. : )

  • edited August 2023

    And yes, I expect to port the remaining classics to HD.

    If you're getting killed, remember some useful spells:Paralyze, Stone Skin, Calm and Magic Immunity.

  • Ah, that solved it. Turns out I had found Rhodo. It was Jaspa. I met someone in the mirror room and just had assumed it was Jaspa. I hadn’t whacked the walls in the mirror room since I thought I already had Jaspa. Thank you again so much.

Sign In or Register to comment.