Metal golems - missing toad golem

Hi !
Did anyone had any trouble with the toad golem ?
From what I understood (from another post), both metal golems are supposed to be in the same room, aren't they ?
I killed one (rooster) but the toad is nowhere to be found...or it's hiding well.

I also encountered the Basilisk glitch btw, it's still in it's tower nagging me but considered dead by Fershid. (I read the topic about that one.)


  • Well, well, well

    For the sake of it I used my eldest save (luckily just in front of the first door in golems' me lucky !)
    and rushed to the room the golems are...and found them both.
    As I didn't like the way things were behind, I used another save much closer to the nusery and tried again...Toad golem was missing...tried with another save midway... toad was missing...
    I used the eldest save again, rushed once more to the nusery and found both golems, dispatched them and cleared my way out.

    I don't know what's wrong.

    But rushing I mean going in, killing what's on my way (ignored the working out room on the way in) and no picking up loot.
    One of the Doors can be opened with a lever or lockpicked; I used the lever; there is another lever on the other side of the Doors(hidden by a plant), I ignored it.
    I killed the nurse and opened the nursery door before deactivating the wall of force.
    Golems were here.
  • I'm glad you found the poor thing.

Sign In or Register to comment.