Argimons dungeon

Hi. I have been going round in circles in HOL1 argimons dungeon. I can’t open the door at the southeast and the one at the south. I have tried different switch combinations...odds and evens and also tried not 1,2,3,5,8,13. Still can’t open them. I haven’t found Cat. I still have the green dragon key and red dragon key (or so I believe) . I have opened the door at the northeast and done that little area....please ( BTW, I finished Caerworn castle. Great game. Thanks Cat and testers)


  • edited February 2021
    Did you had already initiated the quest 'Free Catacomber' from Martelius before you entered Argimon's Dungeon? 😗

    Here's the link of the map for Argimon's Dungeon to assist you with your navigation within that area.

    Also, do have some patience while navigating through Argimon's Dungeon. As technically speaking, this dungeon isn't really that difficult to overcome. 😗
  • Yep, already on the free catacombs quest....

  • I missed a wall.....strewth! I tapped / hit every wall.....or so I thought... I missed the one by K3.. Thnx for the help

  • edited February 2021
    Don't mentioned it. 🙂 I'm glad to hear that you had that issue being resolved. ☺️👍

    But be forewarned, the next dungeon of Argimon's will be quite tough in the next expansion 'HOL II', so do brace yourself. 😯
  • Thanks. Look forward to trying it.

  • I’m stuck in Argimon’s Dungeon as well! I’ve got everything except for K1 - the last key that is behind four energy barriers. Sign on the wall says “3 switches, 1 key”. But I’ve tried every combination of the switches on and off. Still can’t get the key… my brain is melting!
  • If you started playing with the switches, turn them all up. First, turn the left switch down (west switch), then turn the right switch (east switch) down, then turn the north switch down.

  • My god! Thank you Catacomber! I was just about to abandon the quest (not the whole game, just this dungeon) THANK YOU
  • Don't forget to free me. : )

  • You’re free!! Enjoy
  • I've got all the keys and killed Norbert. I have the switches set to the Fibonacci numbers but the teleporter isn't on. Does the order you pull the levers matter? I'm doing them in order (1,2,3,5,8,13).

    I have the Free Catacomber quest and the Argimon's Special item as well


  • edited February 10

    I hope you will free me. Getting pretty hungry in there. ^^

    It doesn't matter which lever you put on iin which order. You need to have these levers on:

    1,2,3,5,8 & 13 on as you do.

    The others (4,6,7,, 9, 10, 11 and 12) need to be off. Are they off?

    Try setting them all off and then switching the correct ones on again. Make sure you have the correct numbers on.

  • I assume #13 is across from the Norbert sign and all the other numbers are directly behind their signs? And "down" is on? (I'll try up instead, guess I never did that)


  • There's a sign next to each switch what number it is. Down is "on".

    Try switching them all "off" (up) and then turn the correct ones down,

    I also had trouble the first time, did that, then it worked.

  • The problem was I was assuming if I read the sign for "1", I should rotate 180 and flip that lever and 13 was just an exception because of the corridor to the north of the sign.... Starting at 13 and strafing down the corridor then back fixed it :)

    I also missed the flag puzzle but now have you rescued as well.

    Now I just need to remember how I bought this expansion for Steam and buy all the rest of them.....


  • Thank you for rescuing me. :)

Sign In or Register to comment.