Cannot Load Celtic Queen on Steam?

Hey, Cat. I am trying to play The Quest on Steam as well. I have all expansions on Apple and Steam, however, I cannot seem to Load the Celtic Queen Expansion on Steam.

Comments

  • Did you try entering from Mithria?

  • edited December 2019

    I just tried loading it myself and didn't have a problem. You followed the arrows up or down for the choices?

    If you still have a problem, write elendil@redshift.hu. I'll write him also.

  • @Catacomber said:
    Did you try entering from Mithria?

    I'll give that a try, I'll head over there. It doesn't seem to be Loaded on the Curated World List on Steam.

  • Have you tried updating Steam recently?

  • This is Elendil's answer when I wrote him:

    "For having trouble with Steam downloads I recommend the user going to
    the expansions Steam page, unsubscribing, starting the game, exiting the
    game, resubscribing and restarting the game. Steam should redownload the
    expansion."

  • I'll give that a shot. Thanks Cat.

Sign In or Register to comment.