Three last things...

GREAT EXPANSION! So atmospheric!

I seem to have killed the Basilisk, which is cool because I didn't realise I had: the room filled with monsters and I thought he had got away! However it's done, quest cleared, yay.

But three more things:

  1. There's red door in the south-west end of Basilisk's Lair that I can't open or find a key for.

  2. Where is Sonali, the housekeeper in Lord Zephyr's Palace? Hers seems to be the one quest I haven't done.

  3. I never found a way inside the Fruit Bat Caves. (I assume there is some hole leading to an interior?) So I ended up buying Fire Opals to complete the quest, which worked.

Also as a final thing, there are some flowers in the north which I can't pick. What were they for?

Comments

  • The red door---you need a guard's key.
    Sonali is on the upper floor, northeast, of his Palace.
    Entrance to Fruit Bat Caves is a hole in a wall in the Mideast of the Fruit Bat Caves surface map.
    I'd need to know the exact location of the flowers. They might just be decorative but can't say without more definite location.

  • Yay thank you! I had managed to miss that whole upstairs section at the palace, so was also able to do a kill-the-tiger quest there.

    Found the guard's key - yay!

    Found the Fruit Bat Caves - yay! Couldn't manage to clear the area, I found three wall switches but couldn't find the last or what walls had opened. By the way the cracks etc there appear to give infinite jewels, was that intentional?

    The flowers are to the north, probably not important. I can't find them now!

  • Checked the cracks in the Fruit Bat Caves and couldn't find any that give infinite jewels. You can get a large amount of Fire Opals there as there are a lot of cracks. But each crack, after you get the gems, changes its state and you get a messge the vein is dry. Unless I missed something but carefully checked each crack. If you can pinpoint the exact crack or cracks, I could recheck.

  • I'm pretty sure it's all of them, including the rock in the north west you walk over which gives you a couple. I just tried it again from a save game and the two cracks and rock I tried all did this.

    I made you a video specially to show it!

  • It's the rocks. The cracks seem ok. Thanks for taking the trouble to make the video. I'll fix that in an update.

  • The cracks do it multiple times as well for me though? I only showed that one twice, but it goes and goes.

    I hope my save game isn't bugged :(

  • I didn't have any problem with the cracks, just the rocks.

Sign In or Register to comment.